Výrazy lambda nie sú podporované v zdroji 1.7 (na povolenie výrazov lambda použite zdroj-8 alebo vyšší)

Lambda Expressions Are Not Supported Source 1



1.idea's sdk, jdk bol tiež nastavený na java1.8
obrázok
obrázok
2. Lokálne prostredie jvm je tiež 1,8
obrázok
je stále taký
obrázok
Zistil som, že prostredie Java pre moju konfiguráciu maven nie je 1,8. Vyberte konfiguračný súbor maven, ktorý používa nápad
obrázok
Umiestnenie súboru pom projektu sa upraví:

obrázok



Odkaz je reprodukovaný: https://blog.csdn.net/qwdafedv/article/details/54691740